Concur Mobile App Troubleshooting

Use this article to troubleshoot the SAP Concur mobile app.

Problem

When you open the SAP Concur mobile app on Android, you receive an error: "The SAP Concur Mobile app was not able to detect a default browser on this device.  Please make sure to set a default browser in order to use the app."


Cause

Avadel applications on Android run in a secure container on the phone called a Work Profile that keeps personal and work data separate.  This error indicates that there is no browser app installed in the Work Profile where the Concur app is running.


Resolution

Install the Microsoft Edge browser app from the Managed Play Store in the Work Profile.
These steps are based on a Samsung Galaxy phone.  Other Android phones may differ slightly.
  1. Open the Android App drawer, e.g. swipe up from the home screen.
  2. Tap to select the Work tab to view Work Profile apps.
  3. Tap to open the Play Store (with the briefcase icon).
  4. Tap to select Microsoft Edge
  5. Tap Install and wait for app to install.
  6. Return to Home screen and re-open the Concur app.